UseBB 1.0.2 released

Submitted by Anonymous on Fri, 09/15/2006 - 16:31
Written by
Dietrich

The UseBB Team is happy to announce version 1.0.2 of the light and Open Source PHP/MySQL bulletin board package "UseBB".

Version 1.0.2 is a minor bug fix release. Changes include but are not limited to:
- Reply-To header support for emails (required on some hosts);
- security fix for the PHP Zend_Hash_Del_Key_Or_Index vulnerability;
- various bugs fixed throughout the whole board;
- limited performance improvements on topic view.

Upgrading is, as always, recommended. Visit http://www.usebb.net/downloads/ for downloads. Information about upgrading is available in the docs/index.html document.

The "PHP Zend_Hash_Del_Key_Or_Index vulnerability", also known as the "unset() vulnerability", is NOT a problem in UseBB itself but a weakness that existed in PHP until version 4.4.3 and 5.1.4. If you run a vulnerable PHP version, it is recommended to update UseBB. For more information, see http://www.hardened-php.net/hphp/zend_hash_del_key_or_index_vulnerability.html.

This release is also the first one to distribute new "changed files packages" containing only the changed files since the previous release. For more info, see the docs/index.html document.

Dietrich

This release is also the first one to distribute new "changed files packages" containing only the changed files since the previous release. For more info, see the docs/index.html document.

Thats what I did, not a problem to report, thanks for having that option.

Congratulations!!
I want to try this version now. :mrgreen:

Next-Step

Sun, 09/17/2006 - 16:21

Congratulations Dietrich! :)

...And I just completed my first modification for this new version... :)

Nice, i'll update as soon as i can.

Congrat . thanks for hard work . :)